GPSim Gui Module: Class List

GPSim Gui Module 1.0.0.0
Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
C AppLogger
C AppLoggerContext
C GPAboutDialog
C GPBusConfigDialog
C GPFindDialog
C GPInterfaceItem
C GPSimInterfaceManager
C GPSimMainWindow
C GPSimPluginsManager
C GuiInterfaceItem
C ICDInfo
C messageEventHandler
C QArgOption
C QCmdLineArgParser
C QDragDropTableView
C QLedButton
C QMyPlainTextEdit
C QPluginAction
C QPyScriptFrame
C QPyScriptModel
C QPyScriptThread
C tabPressHandler
Generated on Mon Feb 6 2023 08:56:16 for GPSim Gui Module by doxygen 1.8.14


GPSim Gui Module: AppLogger Class Reference

Public Member Functions | Static Public Member Functions | List of all members
AppLogger Class Reference

Public Member Functions

void | setLogFile (std::string)
void | sendLog (AppLoggerType type, const AppLoggerContext &context, const std::string &msg)

Static Public Member Functions

static AppLogger * new_AppLogger ()
The documentation for this class was generated from the following files:
  • include/gplogger.h
  • src/gplogger.cpp


GPSim Gui Module: AppLoggerContext Struct Reference

Public Attributes | List of all members
AppLoggerContext Struct Reference

Public Attributes

const char * | file
const char * | function
int | line
The documentation for this struct was generated from the following file:
  • include/gplogger.h


GPSim Gui Module: GPAboutDialog Class Reference

Public Member Functions | List of all members
GPAboutDialog Class Reference
Inheritance diagram for GPAboutDialog:

Public Member Functions

GPAboutDialog (QWidget *parent=0)
void | setApplicationAbout (QString t)
void | setSessionAbout (QString t)
void | setPluginsAbout (QStringList l)
void | setBusAbout (QStringList l)
The documentation for this class was generated from the following files:
  • include/gpabout.h
  • src/gpabout.cpp


GPSim Gui Module: GPBusConfigDialog Class Reference

Public Slots | Signals | Public Member Functions | List of all members
GPBusConfigDialog Class Reference
Inheritance diagram for GPBusConfigDialog:

Public Slots

void | onChanges (QString)
void | onClicked (QAbstractButton *)
void | onProcessed ()

Signals

void processed ()

Public Member Functions

GPBusConfigDialog (QWidget *parent=0)
void | onSetICDHandler (ICDHandler *h)
std::string | getXMLfile ()
The documentation for this class was generated from the following files:
  • include/gpbusconfigdialog.h
  • src/gpbusconfigdialog.cpp


GPSim Gui Module: GPFindDialog Class Reference

Public Slots | Public Member Functions | List of all members
GPFindDialog Class Reference
Inheritance diagram for GPFindDialog:

Public Slots

void ondoubleclicked (QListWidgetItem *)

Public Member Functions

GPFindDialog (QWidget *parent=0)
The documentation for this class was generated from the following files:
  • include/gpfinddialog.h
  • src/gpfinddialog.cpp


GPSim Gui Module: GPInterfaceItem Class Reference

Public Member Functions | List of all members
GPInterfaceItem Class Reference
Inheritance diagram for GPInterfaceItem:

Public Member Functions

GPInterfaceItem (std::string id, std::string name, QMenu *m)
bool | start ()
bool | stop ()
bool | isStarted ()
bool | hasPendingChanges ()
GPInterfaceItem::hasPendingChanges. More...
int | buslogStart (int level, std::string dirName)
GPInterfaceItem::buslogStart. More...
void | buslogStop ()
GPInterfaceItem::buslogStop.
void | onPluginAction (unsigned int id)
void | update ()
GPInterfaceItem::update It synchronize QMenu Checkable items with plugin item.
void | initialise ()
virtual int | onCommitChanges ()
bool | addItem (ICDUiObject *item)
bool | removeItem (unsigned int pos)
bool | removeItem (ICDUiObject *el)
int | indexOf (ICDUiObject *)
ICDUiObject * | getItem (unsigned int pos)
size_t | size ()
void | rename (std::string n)

Member Function Documentation

◆ buslogStart()

int GPInterfaceItem::buslogStart | ( | int | level,
 |  | std::string | dirName
 | ) |  |

GPInterfaceItem::buslogStart.

Parameters
level
dirName
Returns

◆ hasPendingChanges()

bool GPInterfaceItem::hasPendingChanges ( )

GPInterfaceItem::hasPendingChanges.

Returns
bool
The documentation for this class was generated from the following files:
  • include/gpsiminterfacemanager.h
  • src/gpsiminterfacemanager.cpp


GPSim Gui Module: GPSimInterfaceManager Class Reference

Public Member Functions | Static Public Member Functions | List of all members
GPSimInterfaceManager Class Reference
Inheritance diagram for GPSimInterfaceManager:

Public Member Functions

bool | addInterface (GenericInterfaceItem *item)
bool | removeInterface (unsigned int pos)
bool | removeInterface (GenericInterfaceItem *el)
int | indexOf (GenericInterfaceItem *)
int | indexOf (std::string)
GenericInterfaceItem * | getInterface (unsigned int pos)
size_t | size ()

Static Public Member Functions

static GPSimInterfaceManager * getInstance ()
The documentation for this class was generated from the following files:
  • include/gpsiminterfacemanager.h
  • src/gpsiminterfacemanager.cpp


GPSim Gui Module: GPSimMainWindow Class Reference

Classes | Public Slots | Public Member Functions | Static Public Member Functions | List of all members
GPSimMainWindow Class Reference
Inheritance diagram for GPSimMainWindow:

Public Slots

void | newPythonTerminal ()
GPSimMainWindow::newPythonTerminal.
void | removeTabByIndex (int)
GPSimMainWindow::removeTabByIndex It remove a widget referrend by the tab index from the python tab widget. More...
void | removeTabByObj (QWidget *)
GPSimMainWindow::removeTabByObj It remove the given widget from the python tab widget. More...
void | updatePyActionsByTab (int)
GPSimMainWindow::updatePyActionsByTab Update the actions by current python tab The actions is enabled only for scripting purpose. More...
void | onPyFrameStateChanged ()
void | toggleGuiWidget ()
GPSimMainWindow::toggleGuiWidget.
void | togglePythonWidget ()
GPSimMainWindow::togglePythonWidget.
void | manageToolBox (int)
void | onAbout ()
GPSimMainWindow::onAbout.
void | onHelpItem (QAction *)
void | onExit ()
void | setGuiFont ()
void | onFind ()
void | editInterface (QAction *)
int | messageBox (QString caption, QString text, unsigned int btn_flag, unsigned int icon_flag)
QString | inputDialog (QString caption, QString text)
QString | openFileDialog (QString caption, QString dir, QString filters)
QString | saveFileDialog (QString caption, QString dir, QString filters)
QString | dirDialog (QString caption, QString dir)

Public Member Functions

GPSimMainWindow (QString session, QWidget *parent=0)
GPSimMainWindow::GPSimMainWindow. More...
GPSimMainWindow (QFileInfo inifile, QWidget *parent=0)
~GPSimMainWindow ()
GPSimMainWindow::~GPSimMainWindow.
void | create ()
void | initialise ()
int | runAsCli ()
GPSimMainWindow::runAsCli.
int | runBatchScript (QString)
GPSimMainWindow::runBatchScript. More...
int | runAsGui ()
GPSimMainWindow::runAsGui.
QString | getStyleSheetFile () const
QString | getSession ()
std::string | getVersionString ()

Static Public Member Functions

static void | setApplicationData (QString s)
GPSimMainWindow::setApplicationData. More...
static QString | getApplicationData ()
GPSimMainWindow::getApplicationData. More...
static void | setPythonHome (QString s)
static QMenu * | parsePluginAction (ICDPluginObject *plugin, QMenu *, ICDPluginAction *)
GPSimMainWindow::parsePluginAction Parse over plugin's actions and, when not already done, make a related QAction or QMenu object depending on kind and type plugin property. More...

Constructor & Destructor Documentation

◆ GPSimMainWindow()

GPSimMainWindow::GPSimMainWindow | ( | QString | session,
 |  | QWidget * | parent = 0
 | ) |  |
explicit

GPSimMainWindow::GPSimMainWindow.

Parameters
parent

QSettings::setPath

Member Function Documentation

◆ getApplicationData()

QString GPSimMainWindow::getApplicationData ( )
static

GPSimMainWindow::getApplicationData.

Returns
application data path

◆ parsePluginAction()

QMenu * GPSimMainWindow::parsePluginAction | ( | ICDPluginObject * | plugin,
 |  | QMenu * | cur_menu,
 |  | ICDPluginAction * | cur_action
 | ) |  |
static

GPSimMainWindow::parsePluginAction Parse over plugin's actions and, when not already done, make a related QAction or QMenu object depending on kind and type plugin property.

Parameters
plugin object ( the main object )
cur_menu
cur_action
Returns
new QMenu item when type is ACTION_TYPE_MENU or the cur_menu if ation kind is not of type python-only

◆ removeTabByIndex

void GPSimMainWindow::removeTabByIndex ( int i )
slot

GPSimMainWindow::removeTabByIndex It remove a widget referrend by the tab index from the python tab widget.

Parameters
i is the reference of the widget to remove

◆ removeTabByObj

void GPSimMainWindow::removeTabByObj ( QWidget * w )
slot

GPSimMainWindow::removeTabByObj It remove the given widget from the python tab widget.

Parameters
w is the widget pointer to remove

◆ runBatchScript()

int GPSimMainWindow::runBatchScript ( QString filename )

GPSimMainWindow::runBatchScript.

Parameters
filename

◆ setApplicationData()

void GPSimMainWindow::setApplicationData ( QString s )
static

GPSimMainWindow::setApplicationData.

Parameters
s application data value

◆ updatePyActionsByTab

void GPSimMainWindow::updatePyActionsByTab ( int i )
slot

GPSimMainWindow::updatePyActionsByTab Update the actions by current python tab The actions is enabled only for scripting purpose.

Parameters
i
The documentation for this class was generated from the following files:
  • include/gpsimmainwindow.h
  • src/gpsimmainwindow.cpp


GPSim Gui Module: GPSimPluginsManager Class Reference

Public Member Functions | Static Public Member Functions | List of all members
GPSimPluginsManager Class Reference
Inheritance diagram for GPSimPluginsManager:

Public Member Functions

void | setMenu (QMenu *m)
bool | addPluginInterface (GenericInterfaceItem *item)
bool | removePluginInterface (unsigned int pos)
bool | removePluginInterface (GenericInterfaceItem *el)
GenericInterfaceItem * | getPluginInterface (unsigned int pos)
int | indexOf (GenericInterfaceItem *)
int | indexOf (std::string n)
size_t | size ()
void | onPluginAction (GenericInterfaceItem *item, unsigned int id)

Static Public Member Functions

static GPSimPluginsManager * getInstance ()
The documentation for this class was generated from the following files:
  • include/gpsimpluginsmanager.h
  • src/gpsimpluginsmanager.cpp


GPSim Gui Module: GuiInterfaceItem Class Reference

Public Slots | Public Member Functions | List of all members
GuiInterfaceItem Class Reference
Inheritance diagram for GuiInterfaceItem:

Public Slots

void | update ()
void | onBusStart (bool)
void | onBusStop (bool)
void | onBusConfigure (bool)
void | onBusLog (bool)
void | onBusLogChooseDir ()
void | onLogTimer ()
void | onExportBusErrors ()
void | onBusErrorTimer ()
void | onSelectedAperiodicMessage (QAction *)
void | onSendAperiodicMessage ()
void | onSelectedErrorInject (QAction *)
void | onToggleErrorInject (bool)
void | onCommitChanges ()
void | onRevertChanges ()
void | onValueChanged ()
void | onBusButtonClicked (QAbstractButton *btn)

Public Member Functions

GuiInterfaceItem (QICDObjectHandler *objhandler, GenericInterfaceItem *objinterfaceitem, QWidget *parent=0)
GuiInterfaceItem::GuiInterfaceItem. More...
bool | consumeICDEvent (unsigned int req_id, unsigned long event_number)
void | setSettings (QSettings *)
void | hideInterfaceControlWidgets (bool)

Constructor & Destructor Documentation

◆ GuiInterfaceItem()

GuiInterfaceItem::GuiInterfaceItem | ( | QICDObjectHandler * | objhandler,
 |  | GenericInterfaceItem * | objinterfaceitem,
 |  | QWidget * | parent = 0
 | ) |  |
explicit

GuiInterfaceItem::GuiInterfaceItem.

Parameters
objhandler
objinterfaceitem
parent
The documentation for this class was generated from the following files:
  • include/guiinterfaceitem.h
  • src/guiinterfaceitem.cpp


GPSim Gui Module: ICDInfo Class Reference

Public Attributes | List of all members
ICDInfo Class Reference

Public Attributes

ICDHandler * | handler
ICDPluginObject * | plugin
GenericBusObject * | bus
The documentation for this class was generated from the following files:
  • include/icdinfo.h
  • src/icdinfo.cpp


GPSim Gui Module: messageEventHandler Class Reference

Public Slots | Public Member Functions | Protected Member Functions | List of all members
messageEventHandler Class Reference
Inheritance diagram for messageEventHandler:

Public Slots

void onSendReceive ()

Public Member Functions

messageEventHandler (QAction *, QToolButton *, QWidget *parent=NULL)

Protected Member Functions

bool eventFilter (QObject *watched, QEvent *event) override
The documentation for this class was generated from the following files:
  • include/guiinterfaceitem.h
  • src/guiinterfaceitem.cpp


GPSim Gui Module: QArgOption Class Reference

Public Member Functions | Friends | List of all members
QArgOption Class Reference

Public Member Functions

QArgOption (QString opt_long, QChar opt_short, QString desc, bool with_value=false, bool mandatory=false)
bool | parse (QStringList args)
void | setDesc (QString d)
bool | getFound ()
QString | getValue ()
QString | getShortDesc ()
QString | getLongDesc ()

Friends

class QCmdLineArgParser
The documentation for this class was generated from the following file:
  • include/qcmdlineparser.h


GPSim Gui Module: QCmdLineArgParser Class Reference

Public Member Functions | List of all members
QCmdLineArgParser Class Reference

Public Member Functions

bool | parse (QStringList)
void | append (QArgOption *o)
QArgOption * | at (unsigned int i)
QString | getShortDesc ()
QString | getLongDesc ()
The documentation for this class was generated from the following file:
  • include/qcmdlineparser.h


GPSim Gui Module: QDragDropTableView Class Reference

Signals | Public Member Functions | Protected Member Functions | List of all members
QDragDropTableView Class Reference
Inheritance diagram for QDragDropTableView:

Signals

void dragged (QString)

Public Member Functions

QDragDropTableView (QWidget *parent=0)

Protected Member Functions

void | dragMoveEvent (QDragMoveEvent *event)
void | dragEnterEvent (QDragEnterEvent *event)
void | dragLeaveEvent (QDragLeaveEvent *event)
void | dropEvent (QDropEvent *event)
The documentation for this class was generated from the following files:
  • include/qdragdroptableview.h
  • src/qdragdroptableview.cpp


GPSim Gui Module: QLedButton Class Reference

Public Member Functions | Protected Member Functions | List of all members
QLedButton Class Reference
Inheritance diagram for QLedButton:

Public Member Functions

QLedButton (QWidget *parent)

Protected Member Functions

void mousePressEvent (QMouseEvent *event)
The documentation for this class was generated from the following file:
  • include/qledbutton.h


GPSim Gui Module: QMyPlainTextEdit Class Reference

Public Slots | Public Member Functions | List of all members
QMyPlainTextEdit Class Reference
Inheritance diagram for QMyPlainTextEdit:

Public Slots

void toTheEnd ()

Public Member Functions

QMyPlainTextEdit (QWidget *parent=NULL)
void setSelectable (bool)
The documentation for this class was generated from the following files:
  • include/qmyplaintextedit.h
  • src/qmyplaintextedit.cpp


GPSim Gui Module: QPluginAction Class Reference

Public Slots | Public Member Functions | List of all members
QPluginAction Class Reference
Inheritance diagram for QPluginAction:

Public Slots

void trigger (bool)

Public Member Functions

QPluginAction (ICDPluginAction *, ICDPluginObject *)
The documentation for this class was generated from the following files:
  • include/qpluginaction.h
  • src/qpluginaction.cpp


GPSim Gui Module: QPyScriptFrame Class Reference

Public Types | Public Slots | Signals | Public Member Functions | Static Public Member Functions | Properties | List of all members
QPyScriptFrame Class Reference
Inheritance diagram for QPyScriptFrame:

Public Types

enum states { ST_EMPTY_LIST, ST_IDLE, ST_RUNNNING }

Public Slots

void | clearOutput ()
QPyScriptFrame::clearOutput.
void | run ()
QPyScriptFrame::run.
void | abort ()
QPyScriptFrame::stop.
void | terminated ()
void | cutSelectedScript ()
QPyScriptFrame::cutSelectedScript.
void | loadScript ()
QPyScriptFrame::loadScript.
void | saveScriptList ()
QPyScriptFrame::saveScriptList.
void | loadScriptList ()
QPyScriptFrame::loadScriptList.
void | moveScriptUp ()
QPyScriptFrame::moveScriptUp.
void | moveScriptDown ()
QPyScriptFrame::moveScriptDown.
void | onStateChanged ()
QPyScriptFrame::onStateChanged.
void | showContextMenu (QPoint)
QPyScriptFrame::showContextMenu. More...

Signals

void | scripts_loaded ()
void | empty_list ()
void | thread_started ()
void | thread_terminated ()
void | stateChanged ()

Public Member Functions

QPyScriptFrame (QStringList general_info, QWidget *parent=0)
QPyScriptFrame::QPyScriptFrame. More...
~QPyScriptFrame ()
QPyScriptFrame::~QPyScriptFrame.
unsigned int | getChannel ()
QPyScriptFrame::getChannel. More...
QActionGroup * | getActions ()
void | enableActions (bool b)
int | state () const
state More...
QTableView * | getUiScriptListObj ()
QPyScriptFrame::getUiScriptListObj. More...
QPlainTextEdit * | getUiScriptOutputObj ()
void | appendLog (QString msg, enum QMessageBox::Icon i=QMessageBox::NoIcon)
QPyScriptFrame::appendLog. More...
int | writeLogFile (QString script_file, int from)
PySession * | session () const

Static Public Member Functions

static QString getTestHeader (QString script_file)

Properties

int state

Constructor & Destructor Documentation

◆ QPyScriptFrame()

QPyScriptFrame::QPyScriptFrame | ( | QStringList | general_info,
 |  | QWidget * | parent = 0
 | ) |  |
explicit

QPyScriptFrame::QPyScriptFrame.

Parameters
parent

Member Function Documentation

◆ appendLog()

void QPyScriptFrame::appendLog | ( | QString | msg,
 |  | enum QMessageBox::Icon | i = QMessageBox::NoIcon
 | ) |  |

QPyScriptFrame::appendLog.

Parameters
msg
i

◆ getChannel()

unsigned int QPyScriptFrame::getChannel ( )

QPyScriptFrame::getChannel.

Returns
the channel associated to the python interpreter

◆ getUiScriptListObj()

QTableView * QPyScriptFrame::getUiScriptListObj ( )

QPyScriptFrame::getUiScriptListObj.

Returns

◆ showContextMenu

void QPyScriptFrame::showContextMenu ( QPoint p )
slot

QPyScriptFrame::showContextMenu.

Parameters
p

◆ state()

int QPyScriptFrame::state ( ) const
inline

state

Returns
return the currect state
The documentation for this class was generated from the following files:
  • include/qpyscriptframe.h
  • src/qpyscriptframe.cpp


GPSim Gui Module: QPyScriptModel Class Reference

Public Member Functions | List of all members
QPyScriptModel Class Reference
Inheritance diagram for QPyScriptModel:

Public Member Functions

QPyScriptModel (QObject *parent=NULL)
int | rowCount (const QModelIndex &parent=QModelIndex()) const
int | columnCount (const QModelIndex &parent=QModelIndex()) const
QVariant | data (const QModelIndex &index, int role) const
QVariant | headerData (int section, Qt::Orientation orientation, int role) const
bool | removeRows (int position, int rows, const QModelIndex &parent=QModelIndex())
bool | insertRows (int position, int rows, const QModelIndex &index)
bool | setData (const QModelIndex &index, const QVariant &value, int role)
The documentation for this class was generated from the following files:
  • include/qpyscriptmodel.h
  • src/qpyscriptmodel.cpp


GPSim Gui Module: QPyScriptThread Class Reference

Public Member Functions | Protected Member Functions | List of all members
QPyScriptThread Class Reference
Inheritance diagram for QPyScriptThread:

Public Member Functions

QPyScriptThread (QPyScriptFrame *parent)
bool abort ()

Protected Member Functions

void run ()
The documentation for this class was generated from the following files:
  • include/qpyscriptthread.h
  • src/qpyscriptthread.cpp


GPSim Gui Module: tabPressHandler Class Reference

Public Member Functions | Protected Member Functions | List of all members
tabPressHandler Class Reference
Inheritance diagram for tabPressHandler:

Public Member Functions

tabPressHandler (QWidget *parent, QMenu *menu)

Protected Member Functions

bool eventFilter (QObject *obj, QEvent *event) override
The documentation for this class was generated from the following files:
  • include/guiinterfaceitem.h
  • src/guiinterfaceitem.cpp


GPSim Gui Module: Class Index

Class Index
a | g | i | m | q | t
a
GPBusConfigDialog
i
QCmdLineArgParser QPyScriptThread
GPFindDialog QDragDropTableView
t
AppLogger GPInterfaceItem ICDInfo QLedButton
AppLoggerContext GPSimInterfaceManager
m
QMyPlainTextEdit tabPressHandler
g
GPSimMainWindow QPluginAction
GPSimPluginsManager messageEventHandler QPyScriptFrame
GPAboutDialog GuiInterfaceItem
q
QPyScriptModel
QArgOption
a | g | i | m | q | t


GPSim Gui Module: Class Hierarchy

Class Hierarchy
This inheritance list is sorted roughly, but not completely, alphabetically:
[detail level 12]
C AppLogger
C AppLoggerContext
▼C GenericInterfaceItem
C GPInterfaceItem
▼C GenericInterfaceManager
C GPSimInterfaceManager
▼C GenericPluginsManager
C GPSimPluginsManager
C ICDInfo
▼C ICDUiObject
C GPInterfaceItem
C GuiInterfaceItem
▼C QAbstractTableModel
C QPyScriptModel
C QArgOption
C QCmdLineArgParser
▼C QDialog
C GPAboutDialog
C GPBusConfigDialog
C GPFindDialog
▼C QFrame
C QPyScriptFrame
▼C QMainWindow
C GPSimMainWindow
▼C QObject
C messageEventHandler
C QPluginAction
C tabPressHandler
▼C QPlainTextEdit
C QMyPlainTextEdit
▼C QTableView
C QDragDropTableView
▼C QThread
C QPyScriptThread
▼C QToolButton
C QLedButton
▼C QWidget
C GuiInterfaceItem
▼C XMLParser
C GPBusConfigDialog


GPSim Gui Module: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- a -

  • abort() : QPyScriptFrame
  • appendLog() : QPyScriptFrame

- b -

  • buslogStart() : GPInterfaceItem
  • buslogStop() : GPInterfaceItem

- c -

  • clearOutput() : QPyScriptFrame
  • cutSelectedScript() : QPyScriptFrame

- g -

  • getApplicationData() : GPSimMainWindow
  • getChannel() : QPyScriptFrame
  • getUiScriptListObj() : QPyScriptFrame
  • GPSimMainWindow() : GPSimMainWindow
  • GuiInterfaceItem() : GuiInterfaceItem

- h -

  • hasPendingChanges() : GPInterfaceItem

- l -

  • loadScript() : QPyScriptFrame
  • loadScriptList() : QPyScriptFrame

- m -

  • moveScriptDown() : QPyScriptFrame
  • moveScriptUp() : QPyScriptFrame

- n -

  • newPythonTerminal() : GPSimMainWindow

- o -

  • onAbout() : GPSimMainWindow
  • onStateChanged() : QPyScriptFrame

- p -

  • parsePluginAction() : GPSimMainWindow

- q -

  • QPyScriptFrame() : QPyScriptFrame

- r -

  • removeTabByIndex() : GPSimMainWindow
  • removeTabByObj() : GPSimMainWindow
  • run() : QPyScriptFrame
  • runAsCli() : GPSimMainWindow
  • runAsGui() : GPSimMainWindow
  • runBatchScript() : GPSimMainWindow

- s -

  • saveScriptList() : QPyScriptFrame
  • setApplicationData() : GPSimMainWindow
  • showContextMenu() : QPyScriptFrame
  • state() : QPyScriptFrame

- t -

  • toggleGuiWidget() : GPSimMainWindow
  • togglePythonWidget() : GPSimMainWindow

- u -

  • update() : GPInterfaceItem
  • updatePyActionsByTab() : GPSimMainWindow

- ~ -

  • ~GPSimMainWindow() : GPSimMainWindow
  • ~QPyScriptFrame() : QPyScriptFrame


GPSim Gui Module: Class Members - Functions

- a -

  • abort() : QPyScriptFrame
  • appendLog() : QPyScriptFrame

- b -

  • buslogStart() : GPInterfaceItem
  • buslogStop() : GPInterfaceItem

- c -

  • clearOutput() : QPyScriptFrame
  • cutSelectedScript() : QPyScriptFrame

- g -

  • getApplicationData() : GPSimMainWindow
  • getChannel() : QPyScriptFrame
  • getUiScriptListObj() : QPyScriptFrame
  • GPSimMainWindow() : GPSimMainWindow
  • GuiInterfaceItem() : GuiInterfaceItem

- h -

  • hasPendingChanges() : GPInterfaceItem

- l -

  • loadScript() : QPyScriptFrame
  • loadScriptList() : QPyScriptFrame

- m -

  • moveScriptDown() : QPyScriptFrame
  • moveScriptUp() : QPyScriptFrame

- n -

  • newPythonTerminal() : GPSimMainWindow

- o -

  • onAbout() : GPSimMainWindow
  • onStateChanged() : QPyScriptFrame

- p -

  • parsePluginAction() : GPSimMainWindow

- q -

  • QPyScriptFrame() : QPyScriptFrame

- r -

  • removeTabByIndex() : GPSimMainWindow
  • removeTabByObj() : GPSimMainWindow
  • run() : QPyScriptFrame
  • runAsCli() : GPSimMainWindow
  • runAsGui() : GPSimMainWindow
  • runBatchScript() : GPSimMainWindow

- s -

  • saveScriptList() : QPyScriptFrame
  • setApplicationData() : GPSimMainWindow
  • showContextMenu() : QPyScriptFrame
  • state() : QPyScriptFrame

- t -

  • toggleGuiWidget() : GPSimMainWindow
  • togglePythonWidget() : GPSimMainWindow

- u -

  • update() : GPInterfaceItem
  • updatePyActionsByTab() : GPSimMainWindow

- ~ -

  • ~GPSimMainWindow() : GPSimMainWindow
  • ~QPyScriptFrame() : QPyScriptFrame
Generated on Mon Feb 6 2023 08:56:17 for GPSim Gui Module by doxygen 1.8.14


GPSim Gui Module: File List

File List
Here is a list of all documented files with brief descriptions:
[detail level 12]
▼ include
arch.h
gpabout.h
gpbusconfigdialog.h
gpfinddialog.h
gplogger.h
gpsiminterfacemanager.h
gpsimmainwindow.h
gpsimpluginsmanager.h
guiinterfaceitem.h
icdinfo.h
qcmdlineparser.h
qdragdroptableview.h
qledbutton.h
qmyplaintextedit.h
qpluginaction.h
qpyscriptframe.h
qpyscriptmodel.h
qpyscriptthread.h
version.h
Generated on Mon Feb 6 2023 08:56:17 for GPSim Gui Module by doxygen 1.8.14


GPSim Gui Module: include Directory Reference

  • include
include Directory Reference


GPSim Gui Module: include/arch.h Source File

  • include
arch.h
1 const char *CXX_ARCH="x86_64-w64-mingw32";


GPSim Gui Module: include/gpabout.h Source File

  • include
gpabout.h
1 #ifndef GPABOUT_H
2 #define GPABOUT_H
3
4 #include <QDialog>
5 #include <QTableWidget>
6 #include <QAbstractButton>
7
8
9 #define ABOUT_SPLIT_STRING "@@@"
10
11 namespace Ui {
12 class GPAboutDialog;
13 }
14
15 class GPAboutDialog : public QDialog
16 {
17 Q_OBJECT
18
19 public:
20 explicit GPAboutDialog(QWidget *parent = 0);
21 ~GPAboutDialog();
22 void setApplicationAbout(QString t);
23 void setSessionAbout(QString t);
24 void setPluginsAbout(QStringList l);
25 void setBusAbout(QStringList l);
26
27 private:
28 void fillTableWidgets(QTableWidget *t,QStringList l);
29
30 private slots:
31 void onButtonClicked(QAbstractButton *);
32
33 private:
34 Ui::GPAboutDialog *ui;
35 };
36
37 #endif // GPABOUT_H
Ui
Definition: gpabout.h:11
GPAboutDialog
Definition: gpabout.h:15


GPSim Gui Module: include/gpbusconfigdialog.h Source File

  • include
gpbusconfigdialog.h
1 #ifndef GPBUSCONFIGDIALOG_H
2 #define GPBUSCONFIGDIALOG_H
3 #include <QDialog>
4 #include <QLabel>
5 #include <QLineEdit>
6 #include <QAbstractButton>
7
8 #include "icdutils.h"
9
10 #include "rapidxml/rapidxml.hpp"
11 using namespace rapidxml;
12
13 namespace Ui {
14 class GPBusConfigDialog;
15 }
16
17 class ICDHandler;
18 class GenericBusObject;
19
20 class GPBusConfigDialog : public QDialog, private ICDUtils::XMLParser
21 {
22 Q_OBJECT
23 ICDHandler *_icd_handler;
24 std::string _out_file, _xml_filename;
25
26
27 QMap<QLineEdit *,xml_base<> *> _configList;
28 public:
29 explicit GPBusConfigDialog(QWidget *parent = 0);
30 void onSetICDHandler(ICDHandler *h);
31 ~GPBusConfigDialog();
32 std::string getXMLfile();
33
34 private:
35 QWidget *nodetowidget( QWidget *parent, xml_node<> *xnode );
36 void setButtonEnabled(bool);
37 bool parseXmlFile(std::string xml_file);
38
39 public slots:
40 void onChanges(QString);
41 void onClicked(QAbstractButton *);
42 void onProcessed();
43
44 signals:
45 void processed();
46
47 private:
48 Ui::GPBusConfigDialog *ui;
49 };
50
51 #endif // GPBUSCONFIGDIALOG_H
GPBusConfigDialog
Definition: gpbusconfigdialog.h:20
Ui
Definition: gpabout.h:11
rapidxml


GPSim Gui Module: include/gpfinddialog.h Source File

  • include
gpfinddialog.h
1 #ifndef GPFINDDIALOG_H
2 #define GPFINDDIALOG_H
3
4 #include <QDialog>
5
6 namespace Ui {
7 class GPFindDialog;
8 }
9
10 class QListWidgetItem;
11 class QLabel;
12 class GPFindDialog : public QDialog
13 {
14 Q_OBJECT
15
16 public:
17 explicit GPFindDialog(QWidget *parent = 0);
18 ~GPFindDialog();
19
20 public slots:
21 void ondoubleclicked(QListWidgetItem *);
22
23 private:
24 void search();
25
26 private:
27 Ui::GPFindDialog *ui;
28 private:
29 QWidget *_parent;
30 QList<QLabel*> _labels;
31 };
32
33 #endif // GPFINDDIALOG_H
Ui
Definition: gpabout.h:11
GPFindDialog
Definition: gpfinddialog.h:12


GPSim Gui Module: include/gplogger.h Source File

  • include
gplogger.h
1 #ifndef GPLOGGER_H
2 #define GPLOGGER_H
3
4 #include <cstdio>
5 #include <string>
6
7 enum AppLoggerType {
8 AppLoggerDebug=1,
9 AppLoggerInfo,
10 AppLoggerWarning,
11 AppLoggerError,
12 AppLoggerFatal
13 };
14
15 struct AppLoggerContext
16 {
17 const char *file;
18 const char *function;
19 int line;
20 };
21
22 class AppLogger {
23 FILE *fpLog,*fpDebug;
24 public:
25 static AppLogger* new_AppLogger();
26 void setLogFile(std::string);
27 void sendLog(AppLoggerType type, const AppLoggerContext &context, const std::string &msg);
28 private:
29 AppLogger();
30 static AppLogger* self;
31 };
32
33 #endif // GPLOGGER_H
AppLogger
Definition: gplogger.h:22
AppLoggerContext
Definition: gplogger.h:15


GPSim Gui Module: include/gpsiminterfacemanager.h Source File

  • include
gpsiminterfacemanager.h
1 #ifndef GPSIMINTERFACEMANAGER_H
2 #define GPSIMINTERFACEMANAGER_H
3
4 #pragma push_macro("slots")
5 #undef slots
6 #include <Python.h>
7 #pragma pop_macro("slots")
8
9 #include "genericinterfacemanager.h"
10
11 #include "icdcontainers.h"
12 #include "icdhandler.h"
13 #include "genericbusobject.h"
14 #include "icdplugin.h"
15
16 #include <QMenu>
17 #include <mutex>
18 #include <condition_variable>
19
20 //reimplementation of GenericInterfaceItem
21 class GPInterfaceItem: public GenericInterfaceItem, public ICDUiObject {
22 public:
23 GPInterfaceItem(std::string id, std::string name,QMenu *m);
24 ~GPInterfaceItem();
25
26 bool start();
27 bool stop();
28 bool isStarted();
29 bool hasPendingChanges();
30 int buslogStart(int level, std::string dirName);
31 void buslogStop();
32 void onPluginAction(unsigned int id);
33 void update();
34 void initialise();
35 virtual int onCommitChanges();
36 bool addItem( ICDUiObject *item);
37 bool removeItem(unsigned int pos);
38 bool removeItem( ICDUiObject *el);
39 int indexOf(ICDUiObject *);
40 ICDUiObject *getItem(unsigned int pos);
41 size_t size();
42
43 public:
44 inline void rename(std::string n) { _name = n; }
45
46 private:
47 bool consumeICDEvent(unsigned int req_id, unsigned long event_number);
48
49 private:
50 ICDPluginAction *findPluginActionId(ICDPluginAction *a, unsigned int id);
51
52 private:
53 ICDGenericContainer<ICDUiObject> _items;
54 QMenu *_item_memu, *target_menu_obj;
55 QString _log_dirnanme;
56 QList<QAction*> plugin_action_list;
57 QMap<ICDPluginAction*,QAction*> _plug_map;
58 bool _pending_changes;
59 bool _first_start;
60 std::mutex _send_mutex;
61 std::condition_variable _send_cond;
62 };
63
64 class GPSimInterfaceManager:
65 public GenericInterfaceManager
66 {
67 public:
68 static GPSimInterfaceManager* getInstance();
69 bool addInterface( GenericInterfaceItem *item);
70 bool removeInterface(unsigned int pos);
71 bool removeInterface(GenericInterfaceItem *el);
72 int indexOf(GenericInterfaceItem *);
73 int indexOf(std::string);
74 GenericInterfaceItem *getInterface(unsigned int pos);
75 size_t size();
76
77
78 private:
79 GPSimInterfaceManager();
80 static GPSimInterfaceManager *_self;
81 ICDGenericContainer<GenericInterfaceItem> _items;
82
83 };
84
85 #endif // GPSIMINTERFACEMANAGER_H
GPInterfaceItem::hasPendingChanges
bool hasPendingChanges()
GPInterfaceItem::hasPendingChanges.
Definition: gpsiminterfacemanager.cpp:250
GPInterfaceItem::buslogStart
int buslogStart(int level, std::string dirName)
GPInterfaceItem::buslogStart.
Definition: gpsiminterfacemanager.cpp:231
GPSimInterfaceManager
Definition: gpsiminterfacemanager.h:64
GPInterfaceItem
Definition: gpsiminterfacemanager.h:21
GPInterfaceItem::update
void update()
GPInterfaceItem::update It synchronize QMenu Checkable items with plugin item.
Definition: gpsiminterfacemanager.cpp:268
GPInterfaceItem::buslogStop
void buslogStop()
GPInterfaceItem::buslogStop.
Definition: gpsiminterfacemanager.cpp:257


GPSim Gui Module: include/gpsimmainwindow.h Source File

  • include
gpsimmainwindow.h
1 #ifndef GPSIMMAINWINDOW_H
2 #define GPSIMMAINWINDOW_H
3
4 #include <QMainWindow>
5 #pragma push_macro("slots")
6 #undef slots
7 #include <Python.h>
8 #pragma pop_macro("slots")
9 #include <QMap>
10 #include <QMessageBox>
11 #include <QLibrary>
12 #include <QFileInfo>
13 #include "gpsiminterfacemanager.h"
14 #include "gpsimpluginsmanager.h"
15
16
17
18 #include "icdplugin.h"
19
20 class QSettings;
21 class QSignalMapper;
22 class QPyScriptFrame;
23 class ICDHandlersManager;
24 class PyMainInterp;
25 class PySession;
26 class GPAboutDialog;
27 class GPFindDialog;
28
29 namespace Ui {
30 class GPSimMainWindow;
31 }
32
33 class GPSimMainWindow : public QMainWindow
34 {
35 Q_OBJECT
36 public:
37 static void setApplicationData(QString s);
38 static QString getApplicationData();
39 static void setPythonHome(QString s);
40 private:
41 static std::string _python_home;
42 public:
43 explicit GPSimMainWindow(QString session, QWidget *parent = 0);
44 explicit GPSimMainWindow(QFileInfo inifile, QWidget *parent = 0);
45 ~GPSimMainWindow();
46 void create();
47 void initialise();
48 int runAsCli();
49 int runBatchScript(QString);
50 int runAsGui();
51
52 public slots:
53 void newPythonTerminal();
54 void removeTabByIndex(int);
55 void removeTabByObj(QWidget*);
56 void updatePyActionsByTab(int);
57
58 void onPyFrameStateChanged();
59
60 void toggleGuiWidget();
61 void togglePythonWidget();
62
63 void manageToolBox(int);
64
65 void onAbout();
66 void onHelpItem(QAction *);
67 void onExit();
68 void setGuiFont();
69 void onFind();
70 void editInterface(QAction *);
71
72 int messageBox(QString caption, QString text,unsigned int btn_flag, unsigned int icon_flag);
73 QString inputDialog(QString caption,QString text);
74 QString openFileDialog(QString caption,QString dir,QString filters);
75 QString saveFileDialog(QString caption,QString dir,QString filters);
76 QString dirDialog(QString caption, QString dir);
77 private:
78
79 void closeEvent(QCloseEvent *event);
80
81
82 void createPyScriptTab();
83 void initPython();
84 bool handlePlugin(QString, GenericInterfaceItem *);
85 bool handleBusDriver(QString, QString, GenericInterfaceItem *);
86 public:
87 static QMenu *parsePluginAction(ICDPluginObject *plugin, QMenu *, ICDPluginAction *);
88 private:
89 Ui::GPSimMainWindow *ui;
90 PyMainInterp *interp_main;
91 PySession *interp_main_sub;
92 QPyScriptFrame *pyscript_frame;
93 QSettings *ini_settings;
94 GPSimInterfaceManager *interface_manager;
95 GPSimPluginsManager *plugins_manager;
96 GPAboutDialog *aboutdlg;
97 QStringList startup_pyscripts; //list of python scripts
98 private:
99 //used to store files coming from ini and perform path operation based on dirname
100 class interface_files {
101 QString _dirname;
102 QMap<QString,QString> _f;
103 public:
104 explicit interface_files(const QString& dir):_dirname(dir) {}
105 //the relative path '.' is substituted with _dirname
106 void set(QString k,QString v) {
107 if ( ! v.isEmpty() && v.at(0) == '.' ) _f[k]=_dirname + v.mid(1);
108 else _f[k]=v;
109 }
110 QString get(QString k) {
111 return (_f.contains(k) ) ? _f[k] : QString();
112 }
113 };
114 //Each handler has its own interface_files obj
115 struct interface_handler {
116 public:
117 interface_handler(GenericInterfaceItem *i,interface_files *f):item(i),files(f) {widget=NULL;}
118 GenericInterfaceItem *item;
119 interface_files *files;
120 QWidget *widget;
121 };
122
123
124 QMap<int,interface_handler*> icd_mapper;
125 QMap<int,interface_handler*>::Iterator icd_mapper_it;
126
127 struct plugin_handler {
128 QString plugin_path;
129 ondestroy_t* plugin_destroyer;
130 ICDPluginObject *plugin_obj;
131 plugin_handler(const QString& path ,ondestroy_t* d,ICDPluginObject *o)
132 :plugin_path(path),
133 plugin_destroyer(d),
134 plugin_obj(o)
135 {}
136
137 };
138 std::vector<plugin_handler> plugin_handler_vect;
139
140 //mapper for bus driver symbols ...
141 struct bus_handler {
142 QString bus_path;
143 on_genericdriver_destroy_t* bus_destroyer;
144 GenericDriver *bus_obj;
145
146 bus_handler(const QString& path,on_genericdriver_destroy_t* d,GenericDriver *o)
147 :bus_path(path),
148 bus_destroyer(d),
149 bus_obj(o)
150 {}
151
152 };
153 std::vector<bus_handler> bus_handler_vect;
154
155 //The session
156 QString _session;
157 QString _session_legacy_name;
158 QString _session_legacy_version;
159
160 std::string _version_string;
161 int _error;
162 QString _error_string;
163 QString _plugin_error_string;
164 QString _bus_driver_error_string;
165
166 QString _helpdirname;
167 private:
168 QString _stylesheetfile;
169 public:
170 QString getStyleSheetFile() const;
171
172 public:
173 inline QString getSession() { return this->_session; }
174 inline std::string getVersionString() { return this->_version_string; }
175
176 private:
177 GPFindDialog *_find_dialog;
178 };
179
180
181
182 #endif // GPSIMMAINWINDOW_H
GPSimMainWindow::onAbout
void onAbout()
GPSimMainWindow::onAbout.
Definition: gpsimmainwindow.cpp:1562
GPSimMainWindow::runAsCli
int runAsCli()
GPSimMainWindow::runAsCli.
Definition: gpsimmainwindow.cpp:613
GPSimMainWindow::runAsGui
int runAsGui()
GPSimMainWindow::runAsGui.
Definition: gpsimmainwindow.cpp:694
GPSimMainWindow::setApplicationData
static void setApplicationData(QString s)
GPSimMainWindow::setApplicationData.
Definition: gpsimmainwindow.cpp:154
Ui
Definition: gpabout.h:11
GPSimMainWindow::removeTabByObj
void removeTabByObj(QWidget *)
GPSimMainWindow::removeTabByObj It remove the given widget from the python tab widget.
Definition: gpsimmainwindow.cpp:1191
GPSimPluginsManager
Definition: gpsimpluginsmanager.h:7
GPSimInterfaceManager
Definition: gpsiminterfacemanager.h:64
GPSimMainWindow::parsePluginAction
static QMenu * parsePluginAction(ICDPluginObject *plugin, QMenu *, ICDPluginAction *)
GPSimMainWindow::parsePluginAction Parse over plugin&#39;s actions and, when not already done...
Definition: gpsimmainwindow.cpp:1500
GPFindDialog
Definition: gpfinddialog.h:12
GPSimMainWindow::updatePyActionsByTab
void updatePyActionsByTab(int)
GPSimMainWindow::updatePyActionsByTab Update the actions by current python tab The actions is enabled...
Definition: gpsimmainwindow.cpp:1226
GPAboutDialog
Definition: gpabout.h:15
GPSimMainWindow::getApplicationData
static QString getApplicationData()
GPSimMainWindow::getApplicationData.
Definition: gpsimmainwindow.cpp:163
GPSimMainWindow::removeTabByIndex
void removeTabByIndex(int)
GPSimMainWindow::removeTabByIndex It remove a widget referrend by the tab index from the python tab w...
Definition: gpsimmainwindow.cpp:1205
GPSimMainWindow::GPSimMainWindow
GPSimMainWindow(QString session, QWidget *parent=0)
GPSimMainWindow::GPSimMainWindow.
Definition: gpsimmainwindow.cpp:199
GPSimMainWindow::newPythonTerminal
void newPythonTerminal()
GPSimMainWindow::newPythonTerminal.
Definition: gpsimmainwindow.cpp:1164
GPSimMainWindow::togglePythonWidget
void togglePythonWidget()
GPSimMainWindow::togglePythonWidget.
Definition: gpsimmainwindow.cpp:1263
GPSimMainWindow
Definition: gpsimmainwindow.h:33
GPSimMainWindow::toggleGuiWidget
void toggleGuiWidget()
GPSimMainWindow::toggleGuiWidget.
Definition: gpsimmainwindow.cpp:1235
GPSimMainWindow::~GPSimMainWindow
~GPSimMainWindow()
GPSimMainWindow::~GPSimMainWindow.
Definition: gpsimmainwindow.cpp:1081
GPSimMainWindow::runBatchScript
int runBatchScript(QString)
GPSimMainWindow::runBatchScript.
Definition: gpsimmainwindow.cpp:631
QPyScriptFrame
Definition: qpyscriptframe.h:26


GPSim Gui Module: include/gpsimpluginsmanager.h Source File

  • include
gpsimpluginsmanager.h
1 #ifndef GPSIMPLUGINSMANAGER_H
2 #define GPSIMPLUGINSMANAGER_H
3
4 #include "genericpluginsmanager.h"
5 #include "icdcontainers.h"
6 #include <QMenu>
7 class GPSimPluginsManager: public GenericPluginsManager
8 {
9 public:
10 static GPSimPluginsManager *getInstance();
11 inline void setMenu(QMenu *m) {_plugin_menu=m;}
12 public:
13 bool addPluginInterface( GenericInterfaceItem *item);
14 bool removePluginInterface(unsigned int pos);
15 bool removePluginInterface( GenericInterfaceItem *el);
16 GenericInterfaceItem *getPluginInterface(unsigned int pos);
17 int indexOf(GenericInterfaceItem *);
18 int indexOf(std::string n);
19 size_t size();
20 void onPluginAction(GenericInterfaceItem *item,unsigned int id);
21
22 private:
23 GPSimPluginsManager();
24 static GPSimPluginsManager *_self;
25 ICDGenericContainer<GenericInterfaceItem> _items;
26 QMenu *_plugin_menu;
27 };
28
29 #endif // GPSIMPLUGINSMANAGER_H
GPSimPluginsManager
Definition: gpsimpluginsmanager.h:7


GPSim Gui Module: include/guiinterfaceitem.h Source File

  • include
guiinterfaceitem.h
1 #ifndef ICDINSTANCEFORM_H
2 #define ICDINSTANCEFORM_H
3
4 #include <QWidget>
5 #include <QSettings>
6 #include <QMetaType>
7 #include <QTimer>
8 #include <QActionGroup>
9 #include "icdrapresentation.h"
10 #include "qicdobjecthandler.h"
11 #include "genericinterfacemanager.h"
12
13 #define MESSAGE_PROP_NAME "Message"
14 #define ERROR_INJECTION_PROP_NAME "BusErrorInjectionType"
15
16 #define LOG_LEVEL_PROP_NAME "LogLevel"
17 #define LOG_LEVEL_ERROR_ONLY 1
18 #define LOG_LEVEL_ERROR_AND_CHANGES 2
19 #define LOG_LEVEL_ALWAYS 3
20
21 #define LOG_STRING_START "Start logging"
22 #define LOG_STRING_STOP "Stop logging"
23
24 #include "icdhandler.h"
25
26 class ICDPluginObject;
27 class GenericBusObject;
28 class GPBusConfigDialog;
29
30 class QToolButton;
31 class QAbstractButton;
32 class messageEventHandler : public QObject {
33 Q_OBJECT
34 private:
35 QAction * _action;
36 QToolButton *_btn;
37 ICDMessage *_msg;
38 QMenu *_contextMenu;
39 QAction *_action_counter;
40 QAction *_action_send;
41 QAction *_action_select;
42 QAction *_action_enable_dblclick;
43 public:
44 messageEventHandler(QAction *,QToolButton *,QWidget *parent=NULL);
45
46 protected:
47 bool eventFilter(QObject *watched, QEvent *event) override;
48 public slots:
49 void onSendReceive();
50 };
51
52 class tabPressHandler : public QObject
53 {
54 Q_OBJECT
55 QMenu *_menu;
56 public:
57 tabPressHandler(QWidget *parent,QMenu *menu);
58 protected:
59 bool eventFilter(QObject *obj, QEvent *event) override;
60 };
61
62
63 namespace Ui {
64 class GuiInterfaceItem;
65 }
66
67 class GuiInterfaceItem : public QWidget, public ICDUiObject
68 {
69 Q_OBJECT
70 private:
71 Ui::GuiInterfaceItem *ui;
72 ICDHandler *_icdhandler;
73 QICDObjectHandler *_objhandler;
74 QWidget *_handler_ui;
75 QIcon *_red,*_green,*_bright_red;
76 GenericInterfaceItem *_interface_item;
77 GenericBusObject *_objbus;
78 GPBusConfigDialog *_configdialog;
79 int loglevel;
80 int _cur_action_bus;
81
82 QSettings *_ini_settings;
83
84 QStringList errStringList;
85 QString _cur_log_dir;
86 QTimer _log_timer;
87
88 QTimer _err_timer;
89 long _err_count;
90
91 private:
92 void actionOnBus(bool started);
93 void actionOnBusLog(bool started);
94 void actionOnCommit();
95 void actionOnBusError(BusErrorSeverity s);
96 void triggerActionButtons(bool);
97
98 public:
99 explicit GuiInterfaceItem(QICDObjectHandler *objhandler,
100 GenericInterfaceItem *objinterfaceitem,
101 QWidget *parent = 0);
102 ~GuiInterfaceItem();
103
104 public:
105 bool consumeICDEvent(unsigned int req_id, unsigned long event_number);
106
107 public:
108 void setSettings(QSettings*);
109 void hideInterfaceControlWidgets(bool);
110
111 public slots:
112 void update();
113 void onBusStart(bool);
114 void onBusStop(bool);
115 void onBusConfigure(bool);
116
117 void onBusLog(bool);
118 void onBusLogChooseDir();
119 void onLogTimer();
120
121 void onExportBusErrors();
122 void onBusErrorTimer();
123
124
125
126 void onSelectedAperiodicMessage(QAction *);
127 void onSendAperiodicMessage();
128
129 void onSelectedErrorInject(QAction *);
130 void onToggleErrorInject(bool);
131
132 void onCommitChanges();
133 void onRevertChanges();
134
135 void onValueChanged();
136
137 void onBusButtonClicked(QAbstractButton *btn);
138 private:
139 bool _ignore_bus_action {false};
140 };
141
142 Q_DECLARE_METATYPE(ICDMessage*)
143 #endif // ICDINSTANCEFORM_H
GPBusConfigDialog
Definition: gpbusconfigdialog.h:20
tabPressHandler
Definition: guiinterfaceitem.h:52
messageEventHandler
Definition: guiinterfaceitem.h:32
Ui
Definition: gpabout.h:11
GuiInterfaceItem
Definition: guiinterfaceitem.h:67
GuiInterfaceItem::GuiInterfaceItem
GuiInterfaceItem(QICDObjectHandler *objhandler, GenericInterfaceItem *objinterfaceitem, QWidget *parent=0)
GuiInterfaceItem::GuiInterfaceItem.
Definition: guiinterfaceitem.cpp:146


GPSim Gui Module: include/icdinfo.h Source File

  • include
icdinfo.h
1 #ifndef ICDINFO_H
2 #define ICDINFO_H
3
4 #endif // ICDINFO_H
5 class ICDHandler;
6 class ICDPluginObject;
7 class GenericBusObject;
8
9 class ICDInfo {
10 public:
11 ICDInfo();
12 ICDHandler *handler;
13 ICDPluginObject *plugin;
14 GenericBusObject *bus;
15 };
ICDInfo
Definition: icdinfo.h:9


GPSim Gui Module: include/qcmdlineparser.h Source File

  • include
qcmdlineparser.h
1 #ifndef QCMDLINEPARSER_H
2 #define QCMDLINEPARSER_H
3
4 #include <QString>
5 #include <QStringList>
6 #include <QRegExp>
7 #include <QVector>
8
9 class QCmdLineArgParser;
10 class QArgOption {
11 private:
12 QString _opt_long;
13 QChar _opt_short;
14 QString _desc;
15 QString _val;
16 QRegExp _rxExt;
17 QRegExp _rxSh;
18 bool _found;
19 bool _optval;
20 bool _mandatory;
21 public:
22 QArgOption(QString opt_long, QChar opt_short,QString desc, bool with_value=false, bool mandatory=false);
23 bool parse(QStringList args);
24
25 void setDesc(QString d) { _desc=d; }
26 bool getFound() { return _found; }
27 QString getValue() { return _val; }
28 QString getShortDesc();
29 QString getLongDesc();
30 friend class QCmdLineArgParser;
31 };
32
33 class QCmdLineArgParser {
34 private:
35 QVector<QArgOption*> _opt_vect;
36 public:
37 QCmdLineArgParser() {}
38 bool parse(QStringList);
39 void append(QArgOption *o) { _opt_vect.append(o); }
40 QArgOption *at(unsigned int i);
41 QString getShortDesc();
42 QString getLongDesc();
43 };
44
45 #endif // QCMDLINEPARSER_H
QCmdLineArgParser
Definition: qcmdlineparser.h:33
QArgOption
Definition: qcmdlineparser.h:10


GPSim Gui Module: include/qdragdroptableview.h Source File

  • include
qdragdroptableview.h
1 #ifndef MYTABLEWIDGET_H
2 #define MYTABLEWIDGET_H
3
4 #include <QTableView>
5 #include <QObject>
6 #include <QDragMoveEvent>
7 #include <QtGui>
8 #include <QtCore>
9
10 class QDragDropTableView : public QTableView
11 {
12 Q_OBJECT
13 public:
14 explicit QDragDropTableView(QWidget *parent = 0);
15 protected:
16 void dragMoveEvent(QDragMoveEvent *event);
17 void dragEnterEvent(QDragEnterEvent *event);
18 void dragLeaveEvent(QDragLeaveEvent *event);
19 void dropEvent(QDropEvent *event);
20
21 signals:
22 void dragged(QString);
23 public slots:
24 };
25
26 #endif // MYTABLEWIDGET_H
QDragDropTableView
Definition: qdragdroptableview.h:10


GPSim Gui Module: include/qledbutton.h Source File

  • include
qledbutton.h
1 #ifndef QLEDBUTTON_H
2 #define QLEDBUTTON_H
3
4 #include <QToolButton>
5 #include <QMouseEvent>
6
7 class QLedButton : public QToolButton {
8 public:
9 explicit QLedButton(QWidget *parent):QToolButton(parent) {}
10 protected:
11 void mousePressEvent(QMouseEvent * event) { event->ignore(); }
12
13 };
14
15 #endif // QLEDBUTTON_H
16
QLedButton
Definition: qledbutton.h:7


GPSim Gui Module: include/qmyplaintextedit.h Source File

  • include
qmyplaintextedit.h
1 #ifndef MYPLAINTEXTEDIT_H
2 #define MYPLAINTEXTEDIT_H
3 #include <QPlainTextEdit>
4
5 class QMyPlainTextEdit: public QPlainTextEdit
6 {
7 Q_OBJECT
8
9 public:
10 QMyPlainTextEdit(QWidget *parent=NULL);
11 void setSelectable(bool);
12 public slots:
13 void toTheEnd();
14 private:
15 bool _selectable;
16 };
17
18 #endif
QMyPlainTextEdit
Definition: qmyplaintextedit.h:5


GPSim Gui Module: include/qpluginaction.h Source File

  • include
qpluginaction.h
1 #ifndef QPLUGINACTION_H
2 #define QPLUGINACTION_H
3
4 #include <QObject>
5 #include "icdplugin.h"
6
7 class QPluginAction: public QObject {
8 Q_OBJECT
9 private:
10 ICDPluginAction *_action;
11 ICDPluginObject *_plugin;
12 public:
13 QPluginAction(ICDPluginAction *,ICDPluginObject *);
14 public slots:
15 void trigger(bool);
16
17 };
18
19 #endif // QPLUGINACTION_H
QPluginAction
Definition: qpluginaction.h:7


GPSim Gui Module: include/qpyscriptframe.h Source File

  • include
qpyscriptframe.h
1 #ifndef PYSCRIPTFRAME_H
2 #define PYSCRIPTFRAME_H
3
4 #include <QFrame>
5 #include <QMenu>
6 #include <QMessageBox>
7 #include <QTableView>
8 #include <QStateMachine>
9 #include <QTextCursor>
10
11 #pragma push_macro("slots")
12 #undef slots
13 #include <Python.h>
14 #pragma pop_macro("slots")
15 #include "qinterpreter_common.h"
16
17
18
19 namespace Ui {
20 class QPyScriptFrame;
21 }
22
23 class QPyScriptThread;
24 class QPyConsoleThread;
25
26 class QPyScriptFrame : public QFrame
27 {
28 Q_OBJECT
29 Q_PROPERTY(int state READ state WRITE setState NOTIFY stateChanged)
30
31 public:
32 explicit QPyScriptFrame(QStringList general_info, QWidget *parent = 0);
33 ~QPyScriptFrame();
34
35 unsigned int getChannel();
36 QActionGroup *getActions() { return this->frame_actions; }
37 void enableActions(bool b) { this->frame_actions->setEnabled(b); }
38
39
40 static QString getTestHeader(QString script_file);
41 signals:
42 void scripts_loaded();
43 void empty_list();
44 void thread_started();
45 void thread_terminated();
46
47 void stateChanged();
48
49 public slots:
50 void clearOutput();
51 void run();
52 void abort();
53 void terminated();
54
55 void cutSelectedScript();
56 void loadScript();
57 void saveScriptList();
58 void loadScriptList();
59 void moveScriptUp();
60 void moveScriptDown();
61
62 void onStateChanged();
63 void showContextMenu(QPoint);
64
65 public:
66 enum states {
67 ST_EMPTY_LIST,
68 ST_IDLE,
69 ST_RUNNNING
70 };
76 int state() const { return this->m_state; }
77
78 private slots:
79 void setState(int cur_state) {
80 this->m_state = cur_state;
81 emit stateChanged();
82 }
83
84 public:
85 QTableView *getUiScriptListObj();
86 QPlainTextEdit *getUiScriptOutputObj();
87 void appendLog(QString msg,enum QMessageBox::Icon i=QMessageBox::NoIcon);
88 int writeLogFile(QString script_file, int from);
89
90 private slots:
91 void appendRow(QString s);
92 void moveRow(int from, int to);
93
94 private:
95 Ui::QPyScriptFrame *ui;
96 int history;
97 QStringList historyList;
98 QMenu *mycontextMenu;
99 QActionGroup *frame_actions;
100
101 QPyScriptThread *exec_thread;
102 QPyConsoleThread *_console_thread;
103
104 QStateMachine *state_machine;
105 int m_state;
106
107 QString host,user,remarks;
108 public:
109 PySession * session() const;
110
111 private:
112 QStringList _general_info;
113 };
114
115 #endif // PYSCRIPTFRAME_H
QPyScriptFrame::abort
void abort()
QPyScriptFrame::stop.
Definition: qpyscriptframe.cpp:291
QPyScriptFrame::getChannel
unsigned int getChannel()
QPyScriptFrame::getChannel.
Definition: qpyscriptframe.cpp:135
QPyScriptFrame::moveScriptDown
void moveScriptDown()
QPyScriptFrame::moveScriptDown.
Definition: qpyscriptframe.cpp:379
Ui
Definition: gpabout.h:11
QPyScriptFrame::getUiScriptListObj
QTableView * getUiScriptListObj()
QPyScriptFrame::getUiScriptListObj.
Definition: qpyscriptframe.cpp:141
QPyScriptFrame::state
int state() const
state
Definition: qpyscriptframe.h:76
QPyScriptFrame::clearOutput
void clearOutput()
QPyScriptFrame::clearOutput.
Definition: qpyscriptframe.cpp:163
QPyScriptFrame::appendLog
void appendLog(QString msg, enum QMessageBox::Icon i=QMessageBox::NoIcon)
QPyScriptFrame::appendLog.
Definition: qpyscriptframe.cpp:409
QPyScriptFrame::run
void run()
QPyScriptFrame::run.
Definition: qpyscriptframe.cpp:269
QPyScriptThread
Definition: qpyscriptthread.h:15
QPyScriptFrame::loadScript
void loadScript()
QPyScriptFrame::loadScript.
Definition: qpyscriptframe.cpp:200
QPyScriptFrame::saveScriptList
void saveScriptList()
QPyScriptFrame::saveScriptList.
Definition: qpyscriptframe.cpp:345
QPyScriptFrame::QPyScriptFrame
QPyScriptFrame(QStringList general_info, QWidget *parent=0)
QPyScriptFrame::QPyScriptFrame.
Definition: qpyscriptframe.cpp:27
QPyScriptFrame::~QPyScriptFrame
~QPyScriptFrame()
QPyScriptFrame::~QPyScriptFrame.
Definition: qpyscriptframe.cpp:125
QPyScriptFrame::onStateChanged
void onStateChanged()
QPyScriptFrame::onStateChanged.
Definition: qpyscriptframe.cpp:310
QPyScriptFrame::moveScriptUp
void moveScriptUp()
QPyScriptFrame::moveScriptUp.
Definition: qpyscriptframe.cpp:371
QPyScriptFrame::loadScriptList
void loadScriptList()
QPyScriptFrame::loadScriptList.
Definition: qpyscriptframe.cpp:215
QPyScriptFrame::cutSelectedScript
void cutSelectedScript()
QPyScriptFrame::cutSelectedScript.
Definition: qpyscriptframe.cpp:171
QPyScriptFrame
Definition: qpyscriptframe.h:26
QPyScriptFrame::showContextMenu
void showContextMenu(QPoint)
QPyScriptFrame::showContextMenu.
Definition: qpyscriptframe.cpp:388


GPSim Gui Module: include/qpyscriptmodel.h Source File

  • include
qpyscriptmodel.h
1 #ifndef QPYSCRIPTMODEL_H
2 #define QPYSCRIPTMODEL_H
3 #include <QAbstractTableModel>
4 #include <QFileInfo>
5
6 class QPyScriptModel : public QAbstractTableModel {
7 QList<QFileInfo> m_data;
8 public:
9 QPyScriptModel(QObject * parent = NULL) : QAbstractTableModel{parent} {}
10 int rowCount(const QModelIndex &parent= QModelIndex()) const;
11 int columnCount(const QModelIndex &parent= QModelIndex()) const { return 4; }
12
13 QVariant data(const QModelIndex &index, int role) const;
14 QVariant headerData(int section, Qt::Orientation orientation, int role) const;
15 bool removeRows(int position, int rows, const QModelIndex &parent= QModelIndex());
16 bool insertRows(int position, int rows, const QModelIndex &index);
17 bool setData(const QModelIndex &index, const QVariant &value, int role);
18 };
19
20 #endif // QPYSCRIPTMODEL_H
QPyScriptModel
Definition: qpyscriptmodel.h:6


GPSim Gui Module: include/qpyscriptthread.h Source File

  • include
qpyscriptthread.h
1 #ifndef QPYSCRIPTTHREAD_H
2 #define QPYSCRIPTTHREAD_H
3 #include <Python.h>
4 #include "qinterpreter_common.h"
5
6
7 #include <QThread>
8
9 class QPyScriptFrame;
10 class QTableView;
11 class QPlainTextEdit;
12 class PySession;
13 class QPyConsoleThread;
14
15 class QPyScriptThread : public QThread
16 {
17 Q_OBJECT
18 public:
19 explicit QPyScriptThread(QPyScriptFrame *parent);
20 ~QPyScriptThread();
21 bool abort();
22 protected:
23 void run();
24
25 private:
26 int writeLogFile(QString script_file, int from);
27 void release_callable_object();
28 private:
29 QPyScriptFrame *_parent;
30 QTableView *_ui_script_list;
31 QPlainTextEdit *_ui_output_text;
32 PySession *_interp_sub;
33 QPyConsoleThread *_console_thread;
34 bool _abort_request;
35 };
36
37 #endif // QPYSCRIPTTHREAD_H
QPyScriptThread
Definition: qpyscriptthread.h:15
QPyScriptFrame
Definition: qpyscriptframe.h:26


GPSim Gui Module: include/version.h Source File

  • include
version.h
1 #ifndef VERSION_H
2 #define VERSION_H
3
4 #define STR_HELPER(x) #x
5 #define STR(x) STR_HELPER(x)
6
7 #define VER_ORGANIZATION "LeonardoCompany"
8 #define VER_APPLICATION_NAME "MBT-0282/01"
9
10 #define VER_MAJOR 4
11 #define VER_MINOR 0
12 #define VER_REVISION 12
13 #define VER_BUILD 7
14
15
16 #define VER_FILEVERSION VER_MAJOR,VER_MINOR,VER_REVISION,VER_BUILD
17 #define VER_FILEVERSION_STR STR(VER_MAJOR) "." STR(VER_MINOR) "." STR(VER_REVISION) "." STR(VER_BUILD) "\0"
18
19 #define VER_PRODUCTVERSION VER_MAJOR,VER_MINOR,VER_REVISION,VER_BUILD
20 #define VER_PRODUCTVERSION_STR STR(VER_MAJOR) "." STR(VER_MINOR) "\0"
21
22 #define VER_COMPANYNAME_STR VER_ORGANIZATION
23 #define VER_FILEDESCRIPTION_STR VER_ORGANIZATION " Platform Simulator"
24 #define VER_INTERNALNAME_STR VER_APPLICATION_NAME
25 #define VER_LEGALCOPYRIGHT_STR "Copyright © 2022 " VER_COMPANYNAME_STR
26 #define VER_LEGALTRADEMARKS1_STR "All Rights Reserved"
27 #define VER_LEGALTRADEMARKS2_STR VER_LEGALTRADEMARKS1_STR
28 #define VER_ORIGINALFILENAME_STR VER_APPLICATION_NAME
29 #define VER_PRODUCTNAME_STR VER_APPLICATION_NAME
30
31 #define VER_COMPANYDOMAIN_STR ""
32
33 #endif // VERSION_H


GPSim Gui Module: Member List

AppLogger Member List

This is the complete list of members for AppLogger, including all inherited members.

new_AppLogger() (defined in AppLogger) | AppLogger | static
sendLog(AppLoggerType type, const AppLoggerContext &context, const std::string &msg) (defined in AppLogger) | AppLogger |
setLogFile(std::string) (defined in AppLogger) | AppLogger |


GPSim Gui Module: Member List

GPAboutDialog Member List

This is the complete list of members for GPAboutDialog, including all inherited members.

GPAboutDialog(QWidget *parent=0) (defined in GPAboutDialog) | GPAboutDialog | explicit
setApplicationAbout(QString t) (defined in GPAboutDialog) | GPAboutDialog |
setBusAbout(QStringList l) (defined in GPAboutDialog) | GPAboutDialog |
setPluginsAbout(QStringList l) (defined in GPAboutDialog) | GPAboutDialog |
setSessionAbout(QString t) (defined in GPAboutDialog) | GPAboutDialog |
~GPAboutDialog() (defined in GPAboutDialog) | GPAboutDialog |


GPSim Gui Module: Member List

GPBusConfigDialog Member List

This is the complete list of members for GPBusConfigDialog, including all inherited members.

getXMLfile() (defined in GPBusConfigDialog) | GPBusConfigDialog |
GPBusConfigDialog(QWidget *parent=0) (defined in GPBusConfigDialog) | GPBusConfigDialog | explicit
onChanges(QString) (defined in GPBusConfigDialog) | GPBusConfigDialog | slot
onClicked(QAbstractButton *) (defined in GPBusConfigDialog) | GPBusConfigDialog | slot
onProcessed() (defined in GPBusConfigDialog) | GPBusConfigDialog | slot
onSetICDHandler(ICDHandler *h) (defined in GPBusConfigDialog) | GPBusConfigDialog |
processed() (defined in GPBusConfigDialog) | GPBusConfigDialog | signal
~GPBusConfigDialog() (defined in GPBusConfigDialog) | GPBusConfigDialog |


GPSim Gui Module: Member List

GPFindDialog Member List

This is the complete list of members for GPFindDialog, including all inherited members.

GPFindDialog(QWidget *parent=0) (defined in GPFindDialog) | GPFindDialog | explicit
ondoubleclicked(QListWidgetItem *) (defined in GPFindDialog) | GPFindDialog | slot
~GPFindDialog() (defined in GPFindDialog) | GPFindDialog |


GPSim Gui Module: Member List

GPInterfaceItem Member List

This is the complete list of members for GPInterfaceItem, including all inherited members.

addItem(ICDUiObject *item) (defined in GPInterfaceItem) | GPInterfaceItem |
buslogStart(int level, std::string dirName) | GPInterfaceItem |
buslogStop() | GPInterfaceItem |
getItem(unsigned int pos) (defined in GPInterfaceItem) | GPInterfaceItem |
GPInterfaceItem(std::string id, std::string name, QMenu *m) (defined in GPInterfaceItem) | GPInterfaceItem |
hasPendingChanges() | GPInterfaceItem |
indexOf(ICDUiObject *) (defined in GPInterfaceItem) | GPInterfaceItem |
initialise() (defined in GPInterfaceItem) | GPInterfaceItem |
isStarted() (defined in GPInterfaceItem) | GPInterfaceItem |
onCommitChanges() (defined in GPInterfaceItem) | GPInterfaceItem | virtual
onPluginAction(unsigned int id) (defined in GPInterfaceItem) | GPInterfaceItem |
removeItem(unsigned int pos) (defined in GPInterfaceItem) | GPInterfaceItem |
removeItem(ICDUiObject *el) (defined in GPInterfaceItem) | GPInterfaceItem |
rename(std::string n) (defined in GPInterfaceItem) | GPInterfaceItem | inline
size() (defined in GPInterfaceItem) | GPInterfaceItem |
start() (defined in GPInterfaceItem) | GPInterfaceItem |
stop() (defined in GPInterfaceItem) | GPInterfaceItem |
update() | GPInterfaceItem |
~GPInterfaceItem() (defined in GPInterfaceItem) | GPInterfaceItem |


GPSim Gui Module: Member List

GPSimInterfaceManager Member List

This is the complete list of members for GPSimInterfaceManager, including all inherited members.

addInterface(GenericInterfaceItem *item) (defined in GPSimInterfaceManager) | GPSimInterfaceManager |
getInstance() (defined in GPSimInterfaceManager) | GPSimInterfaceManager | static
getInterface(unsigned int pos) (defined in GPSimInterfaceManager) | GPSimInterfaceManager |
indexOf(GenericInterfaceItem *) (defined in GPSimInterfaceManager) | GPSimInterfaceManager |
indexOf(std::string) (defined in GPSimInterfaceManager) | GPSimInterfaceManager |
removeInterface(unsigned int pos) (defined in GPSimInterfaceManager) | GPSimInterfaceManager |
removeInterface(GenericInterfaceItem *el) (defined in GPSimInterfaceManager) | GPSimInterfaceManager |
size() (defined in GPSimInterfaceManager) | GPSimInterfaceManager |


GPSim Gui Module: Member List

GPSimMainWindow Member List

This is the complete list of members for GPSimMainWindow, including all inherited members.

create() (defined in GPSimMainWindow) | GPSimMainWindow |
dirDialog(QString caption, QString dir) (defined in GPSimMainWindow) | GPSimMainWindow | slot
editInterface(QAction *) (defined in GPSimMainWindow) | GPSimMainWindow | slot
getApplicationData() | GPSimMainWindow | static
getSession() (defined in GPSimMainWindow) | GPSimMainWindow | inline
getStyleSheetFile() const (defined in GPSimMainWindow) | GPSimMainWindow |
getVersionString() (defined in GPSimMainWindow) | GPSimMainWindow | inline
GPSimMainWindow(QString session, QWidget *parent=0) | GPSimMainWindow | explicit
GPSimMainWindow(QFileInfo inifile, QWidget *parent=0) (defined in GPSimMainWindow) | GPSimMainWindow | explicit
initialise() (defined in GPSimMainWindow) | GPSimMainWindow |
inputDialog(QString caption, QString text) (defined in GPSimMainWindow) | GPSimMainWindow | slot
manageToolBox(int) (defined in GPSimMainWindow) | GPSimMainWindow | slot
messageBox(QString caption, QString text, unsigned int btn_flag, unsigned int icon_flag) (defined in GPSimMainWindow) | GPSimMainWindow | slot
newPythonTerminal() | GPSimMainWindow | slot
onAbout() | GPSimMainWindow | slot
onExit() (defined in GPSimMainWindow) | GPSimMainWindow | slot
onFind() (defined in GPSimMainWindow) | GPSimMainWindow | slot
onHelpItem(QAction *) (defined in GPSimMainWindow) | GPSimMainWindow | slot
onPyFrameStateChanged() (defined in GPSimMainWindow) | GPSimMainWindow | slot
openFileDialog(QString caption, QString dir, QString filters) (defined in GPSimMainWindow) | GPSimMainWindow | slot
parsePluginAction(ICDPluginObject *plugin, QMenu *, ICDPluginAction *) | GPSimMainWindow | static
removeTabByIndex(int) | GPSimMainWindow | slot
removeTabByObj(QWidget *) | GPSimMainWindow | slot
runAsCli() | GPSimMainWindow |
runAsGui() | GPSimMainWindow |
runBatchScript(QString) | GPSimMainWindow |
saveFileDialog(QString caption, QString dir, QString filters) (defined in GPSimMainWindow) | GPSimMainWindow | slot
setApplicationData(QString s) | GPSimMainWindow | static
setGuiFont() (defined in GPSimMainWindow) | GPSimMainWindow | slot
setPythonHome(QString s) (defined in GPSimMainWindow) | GPSimMainWindow | static
toggleGuiWidget() | GPSimMainWindow | slot
togglePythonWidget() | GPSimMainWindow | slot
updatePyActionsByTab(int) | GPSimMainWindow | slot
~GPSimMainWindow() | GPSimMainWindow |


GPSim Gui Module: Member List

GPSimPluginsManager Member List

This is the complete list of members for GPSimPluginsManager, including all inherited members.

addPluginInterface(GenericInterfaceItem *item) (defined in GPSimPluginsManager) | GPSimPluginsManager |
getInstance() (defined in GPSimPluginsManager) | GPSimPluginsManager | static
getPluginInterface(unsigned int pos) (defined in GPSimPluginsManager) | GPSimPluginsManager |
indexOf(GenericInterfaceItem *) (defined in GPSimPluginsManager) | GPSimPluginsManager |
indexOf(std::string n) (defined in GPSimPluginsManager) | GPSimPluginsManager |
onPluginAction(GenericInterfaceItem *item, unsigned int id) (defined in GPSimPluginsManager) | GPSimPluginsManager |
removePluginInterface(unsigned int pos) (defined in GPSimPluginsManager) | GPSimPluginsManager |
removePluginInterface(GenericInterfaceItem *el) (defined in GPSimPluginsManager) | GPSimPluginsManager |
setMenu(QMenu *m) (defined in GPSimPluginsManager) | GPSimPluginsManager | inline
size() (defined in GPSimPluginsManager) | GPSimPluginsManager |


GPSim Gui Module: Member List

GuiInterfaceItem Member List

This is the complete list of members for GuiInterfaceItem, including all inherited members.

consumeICDEvent(unsigned int req_id, unsigned long event_number) (defined in GuiInterfaceItem) | GuiInterfaceItem |
GuiInterfaceItem(QICDObjectHandler *objhandler, GenericInterfaceItem *objinterfaceitem, QWidget *parent=0) | GuiInterfaceItem | explicit
hideInterfaceControlWidgets(bool) (defined in GuiInterfaceItem) | GuiInterfaceItem |
onBusButtonClicked(QAbstractButton *btn) (defined in GuiInterfaceItem) | GuiInterfaceItem | slot
onBusConfigure(bool) (defined in GuiInterfaceItem) | GuiInterfaceItem | slot
onBusErrorTimer() (defined in GuiInterfaceItem) | GuiInterfaceItem | slot
onBusLog(bool) (defined in GuiInterfaceItem) | GuiInterfaceItem | slot
onBusLogChooseDir() (defined in GuiInterfaceItem) | GuiInterfaceItem | slot
onBusStart(bool) (defined in GuiInterfaceItem) | GuiInterfaceItem | slot
onBusStop(bool) (defined in GuiInterfaceItem) | GuiInterfaceItem | slot
onCommitChanges() (defined in GuiInterfaceItem) | GuiInterfaceItem | slot
onExportBusErrors() (defined in GuiInterfaceItem) | GuiInterfaceItem | slot
onLogTimer() (defined in GuiInterfaceItem) | GuiInterfaceItem | slot
onRevertChanges() (defined in GuiInterfaceItem) | GuiInterfaceItem | slot
onSelectedAperiodicMessage(QAction *) (defined in GuiInterfaceItem) | GuiInterfaceItem | slot
onSelectedErrorInject(QAction *) (defined in GuiInterfaceItem) | GuiInterfaceItem | slot
onSendAperiodicMessage() (defined in GuiInterfaceItem) | GuiInterfaceItem | slot
onToggleErrorInject(bool) (defined in GuiInterfaceItem) | GuiInterfaceItem | slot
onValueChanged() (defined in GuiInterfaceItem) | GuiInterfaceItem | slot
setSettings(QSettings *) (defined in GuiInterfaceItem) | GuiInterfaceItem |
update() (defined in GuiInterfaceItem) | GuiInterfaceItem | slot
~GuiInterfaceItem() (defined in GuiInterfaceItem) | GuiInterfaceItem |


GPSim Gui Module: Member List

ICDInfo Member List

This is the complete list of members for ICDInfo, including all inherited members.

bus (defined in ICDInfo) | ICDInfo
handler (defined in ICDInfo) | ICDInfo
ICDInfo() (defined in ICDInfo) | ICDInfo
plugin (defined in ICDInfo) | ICDInfo


GPSim Gui Module: Member List

QArgOption Member List

This is the complete list of members for QArgOption, including all inherited members.

getFound() (defined in QArgOption) | QArgOption | inline
getLongDesc() (defined in QArgOption) | QArgOption |
getShortDesc() (defined in QArgOption) | QArgOption |
getValue() (defined in QArgOption) | QArgOption | inline
parse(QStringList args) (defined in QArgOption) | QArgOption |
QArgOption(QString opt_long, QChar opt_short, QString desc, bool with_value=false, bool mandatory=false) (defined in QArgOption) | QArgOption |
QCmdLineArgParser (defined in QArgOption) | QArgOption | friend
setDesc(QString d) (defined in QArgOption) | QArgOption | inline


GPSim Gui Module: Member List

QCmdLineArgParser Member List

This is the complete list of members for QCmdLineArgParser, including all inherited members.

append(QArgOption *o) (defined in QCmdLineArgParser) | QCmdLineArgParser | inline
at(unsigned int i) (defined in QCmdLineArgParser) | QCmdLineArgParser |
getLongDesc() (defined in QCmdLineArgParser) | QCmdLineArgParser |
getShortDesc() (defined in QCmdLineArgParser) | QCmdLineArgParser |
parse(QStringList) (defined in QCmdLineArgParser) | QCmdLineArgParser |
QCmdLineArgParser() (defined in QCmdLineArgParser) | QCmdLineArgParser | inline


GPSim Gui Module: Member List

QDragDropTableView Member List

This is the complete list of members for QDragDropTableView, including all inherited members.

dragEnterEvent(QDragEnterEvent *event) (defined in QDragDropTableView) | QDragDropTableView | protected
dragged(QString) (defined in QDragDropTableView) | QDragDropTableView | signal
dragLeaveEvent(QDragLeaveEvent *event) (defined in QDragDropTableView) | QDragDropTableView | protected
dragMoveEvent(QDragMoveEvent *event) (defined in QDragDropTableView) | QDragDropTableView | protected
dropEvent(QDropEvent *event) (defined in QDragDropTableView) | QDragDropTableView | protected
QDragDropTableView(QWidget *parent=0) (defined in QDragDropTableView) | QDragDropTableView | explicit


GPSim Gui Module: Member List

QLedButton Member List

This is the complete list of members for QLedButton, including all inherited members.

mousePressEvent(QMouseEvent *event) (defined in QLedButton) | QLedButton | inlineprotected
QLedButton(QWidget *parent) (defined in QLedButton) | QLedButton | inlineexplicit


GPSim Gui Module: Member List

QMyPlainTextEdit Member List

This is the complete list of members for QMyPlainTextEdit, including all inherited members.

QMyPlainTextEdit(QWidget *parent=NULL) (defined in QMyPlainTextEdit) | QMyPlainTextEdit |
setSelectable(bool) (defined in QMyPlainTextEdit) | QMyPlainTextEdit |
toTheEnd() (defined in QMyPlainTextEdit) | QMyPlainTextEdit | slot


GPSim Gui Module: Member List

QPluginAction Member List

This is the complete list of members for QPluginAction, including all inherited members.

QPluginAction(ICDPluginAction *, ICDPluginObject *) (defined in QPluginAction) | QPluginAction |
trigger(bool) (defined in QPluginAction) | QPluginAction | slot


GPSim Gui Module: Member List

QPyScriptFrame Member List

This is the complete list of members for QPyScriptFrame, including all inherited members.

abort() | QPyScriptFrame | slot
appendLog(QString msg, enum QMessageBox::Icon i=QMessageBox::NoIcon) | QPyScriptFrame |
clearOutput() | QPyScriptFrame | slot
cutSelectedScript() | QPyScriptFrame | slot
empty_list() (defined in QPyScriptFrame) | QPyScriptFrame | signal
enableActions(bool b) (defined in QPyScriptFrame) | QPyScriptFrame | inline
getActions() (defined in QPyScriptFrame) | QPyScriptFrame | inline
getChannel() | QPyScriptFrame |
getTestHeader(QString script_file) (defined in QPyScriptFrame) | QPyScriptFrame | static
getUiScriptListObj() | QPyScriptFrame |
getUiScriptOutputObj() (defined in QPyScriptFrame) | QPyScriptFrame |
loadScript() | QPyScriptFrame | slot
loadScriptList() | QPyScriptFrame | slot
moveScriptDown() | QPyScriptFrame | slot
moveScriptUp() | QPyScriptFrame | slot
onStateChanged() | QPyScriptFrame | slot
QPyScriptFrame(QStringList general_info, QWidget *parent=0) | QPyScriptFrame | explicit
run() | QPyScriptFrame | slot
saveScriptList() | QPyScriptFrame | slot
scripts_loaded() (defined in QPyScriptFrame) | QPyScriptFrame | signal
session() const (defined in QPyScriptFrame) | QPyScriptFrame |
showContextMenu(QPoint) | QPyScriptFrame | slot
ST_EMPTY_LIST enum value (defined in QPyScriptFrame) | QPyScriptFrame |
ST_IDLE enum value (defined in QPyScriptFrame) | QPyScriptFrame |
ST_RUNNNING enum value (defined in QPyScriptFrame) | QPyScriptFrame |
state (defined in QPyScriptFrame) | QPyScriptFrame |
state() const | QPyScriptFrame | inline
stateChanged() (defined in QPyScriptFrame) | QPyScriptFrame | signal
states enum name (defined in QPyScriptFrame) | QPyScriptFrame |
terminated() (defined in QPyScriptFrame) | QPyScriptFrame | slot
thread_started() (defined in QPyScriptFrame) | QPyScriptFrame | signal
thread_terminated() (defined in QPyScriptFrame) | QPyScriptFrame | signal
writeLogFile(QString script_file, int from) (defined in QPyScriptFrame) | QPyScriptFrame |
~QPyScriptFrame() | QPyScriptFrame |


GPSim Gui Module: Member List

QPyScriptModel Member List

This is the complete list of members for QPyScriptModel, including all inherited members.

columnCount(const QModelIndex &parent=QModelIndex()) const (defined in QPyScriptModel) | QPyScriptModel | inline
data(const QModelIndex &index, int role) const (defined in QPyScriptModel) | QPyScriptModel |
headerData(int section, Qt::Orientation orientation, int role) const (defined in QPyScriptModel) | QPyScriptModel |
insertRows(int position, int rows, const QModelIndex &index) (defined in QPyScriptModel) | QPyScriptModel |
QPyScriptModel(QObject *parent=NULL) (defined in QPyScriptModel) | QPyScriptModel | inline
removeRows(int position, int rows, const QModelIndex &parent=QModelIndex()) (defined in QPyScriptModel) | QPyScriptModel |
rowCount(const QModelIndex &parent=QModelIndex()) const (defined in QPyScriptModel) | QPyScriptModel |
setData(const QModelIndex &index, const QVariant &value, int role) (defined in QPyScriptModel) | QPyScriptModel |


GPSim Gui Module: Member List

QPyScriptThread Member List

This is the complete list of members for QPyScriptThread, including all inherited members.

abort() (defined in QPyScriptThread) | QPyScriptThread |
QPyScriptThread(QPyScriptFrame *parent) (defined in QPyScriptThread) | QPyScriptThread | explicit
run() (defined in QPyScriptThread) | QPyScriptThread | protected
~QPyScriptThread() (defined in QPyScriptThread) | QPyScriptThread |


GPSim Gui Module: Member List

messageEventHandler Member List

This is the complete list of members for messageEventHandler, including all inherited members.

eventFilter(QObject *watched, QEvent *event) override (defined in messageEventHandler) | messageEventHandler | protected
messageEventHandler(QAction *, QToolButton *, QWidget *parent=NULL) (defined in messageEventHandler) | messageEventHandler |
onSendReceive() (defined in messageEventHandler) | messageEventHandler | slot


GPSim Gui Module: Member List

tabPressHandler Member List

This is the complete list of members for tabPressHandler, including all inherited members.

eventFilter(QObject *obj, QEvent *event) override (defined in tabPressHandler) | tabPressHandler | protected
tabPressHandler(QWidget *parent, QMenu *menu) (defined in tabPressHandler) | tabPressHandler |


GPSim Gui Module: src Directory Reference

  • src
src Directory Reference


GPSim Gui Module: Main Page

GPSim Gui Module Documentation


GPSim Gui Module: Member List

AppLoggerContext Member List

This is the complete list of members for AppLoggerContext, including all inherited members.

file (defined in AppLoggerContext) | AppLoggerContext
function (defined in AppLoggerContext) | AppLoggerContext
line (defined in AppLoggerContext) | AppLoggerContext